Bloqueo Youtube y Facebook [Ejemplo]

1) Bloquea a la IP 192.168.1.50 el youtube y el facebook.

Tu no sabes como hacerlo así que pides ayuda a un amigo de como hacerlo, nuestro amigo entonces no te va a mandar toooooodo su backup, el solo va a mandar los scripts en donde se sitúa lo que pides.
El va a su terminal y va a crear los backups que sean necesarios.

Primero va al nivel de layer7-protocol. Para ello entra a cada nivel donde se ubica la direccion layer7
Código:

[admin@MikroTik] > ip
[admin@MikroTik] /ip> firewall
[admin@MikroTik] /ip firewall> layer7-protocol
[admin@MikroTik] /ip firewall layer7-protocol>

Una vez ubicado el nivel damos el comando EXPORT para sacar el backup de la configuracion que necesitamos (es decir no sacamos toooda el backup sino lo que necesitamos y denominamos el backup con el nombre "ReglasdeLayer7"
Código:

[admin@MikroTik] /ip firewall layer7-protocol> export file=ReglasdeLayer7

Ahora nos falta bajar el backup de nuestras reglas para bloquear el facebook y youtube que se encuentran en el firewall filter, entonces vamos al nivel que corresponde al filtro del firewall
Código:

[admin@MikroTik] > ip
[admin@MikroTik] /ip> firewall
[admin@MikroTik] /ip firewall> filter
[admin@MikroTik] /ip firewall filter>

Y creamos un archivo denominado "ReglasdeFiltrodeFirewall" que es el que contiene el backup de todas las reglas de filtro que tine el firewall
Código:

[admin@MikroTik] /ip firewall filter> export file=ReglasdeFiltrodeFirewall

Veremos en nuestro winbox que esos dos backups estan creados

Si abrimos el archivo (con un archivo de texto) llamado "ReglasdeLayer7" veremos esto:
Código:

jul/03/2013 08:32:56 by RouterOS 5.11

software id = 9E7I-HDC8

#
/ip firewall layer7-protocol
add name=facebook regexp="^.(facebook).\\$"
add name=youtube regexp="^.(youtube).\$"

De igual manera si abrimos el archivo (con un archivo de texto) backup llamado "ReglasdeFiltrodeFirewall" veremos esto
Código:

jul/03/2013 08:57:34 by RouterOS 5.11

software id = 9E7I-HDC8

#
/ip firewall filter
add action=drop chain=forward disabled=no layer7-protocol=facebook \
src-address=10.26.13.218
add action=drop chain=forward disabled=no layer7-protocol=youtube \
src-address=10.26.13.218

Y ahora?!!!
Que hacemos nosotros si ya tenemos el script generado que nos mando nuestro amigo
Vimos en el post anterior sobre como podemos guardar backups editables. Ahora vamos a saber mas sobre lo que podemos guardar como backup.
Vamos a utilizar este post sobre como bloquear youtube y facebook en una red.
Este post lo puedes encontrar en la seccion firewall de este foro.
Código:

/ip firewall layer7-protocol
add comment="" name=facebook regexp="^.(facebook).\$"

Traduccion
La primera linea (esta linea /ip firewall layer7-protocol) nos dice que nos vamos a dirigir a la sección IP, en esa seccion nos vamos al nivel FIREWALL y dentro de este nivel hay un subsiguiente nivel llamado LAYER7. Abajo aparece como seria si copiamos esta linea de comando en el TErminal del Mikrotik

La segunda linea ( add comment="" name=facebook regexp="^.(facebook).\$") nos dice AGREGAR un REGEX con nombre FACEBOOK sin NINGUN COMENTARIO
Código:

add comment="" name=facebook regexp="^.(facebook).\$"


Listo ya lo tenemos, visto por el winbox vemos que ya tenemos la regla que colocamos via terminal.

Lo mismo hacemos con la segunda regla que nos ha enviado
Código:

/ip firewall layer7-protocol
add comment="" name=youtube regexp="^.(youtube).\$"

Hasta aqui todo normal pero en la segunda parte donde se ubica las reglas de firewall vemos esto
Código:

/ip firewall filter
add action=drop chain=forward comment="" disabled=no layer7->protocol=facebook src-address=10.26.13.218

Código:

/ip firewall filter
add action=drop chain=forward comment="" disabled=no layer7->protocol=youtube src-address=10.26.13.218

La mayoría de personas cuando se les manda un codigo script acerca de "como sería la configuracion que piden" cometen el error de no leer entre lineas que cosas tienen que cambiar y solo copian y pegan mas no modifican (es ahi su error). Para el ejemplo en el cual estamos trabajando necesitamos bloquear la IP 192.168.1.50 pero si se fijan bien la IP de nuestro amigo que tiene en su red es distinta a la de nosotros. la regla que nos manda de ejemplo es para la Maquina (PC) con IP 10.26.13.218 asi que nosotros tenemos que cambiar ese dato y poner la IP que nosotros queremos.
Código:

/ip firewall filter
add action=drop chain=forward comment="" disabled=no layer7-protocol=facebook src-address=192.168.1.50
Código:
/ip firewall filter
add action=drop chain=forward comment="" disabled=no layer7-protocol=youtube src-address=192.168.1.50
Y asi finalizamos esta sección de backups. Espero que hayan podido entender mas sobre este tema de scripts ya que es de mucha ayuda compartir nuestras configuraciones para asi crear mas y mas reglas.

Tambien con el Pools de servidores Facebook, Si es que tenemos un RB750

Código:

/ip firewall address-list
add address=66.220.144.0/21 comment="Facebook block AS32934" disabled=no \
list=Block-Facebook
add address=66.220.152.0/21 disabled=no list=Block-Facebook
add address=66.220.159.0/24 disabled=no list=Block-Facebook
add address=69.63.176.0/21 disabled=no list=Block-Facebook
add address=69.63.184.0/21 disabled=no list=Block-Facebook
add address=69.171.224.0/20 disabled=no list=Block-Facebook
add address=69.171.239.0/24 disabled=no list=Block-Facebook
add address=69.171.240.0/20 disabled=no list=Block-Facebook
add address=69.171.255.0/24 disabled=no list=Block-Facebook
add address=74.119.76.0/22 disabled=no list=Block-Facebook
add address=204.15.20.0/22 disabled=no list=Block-Facebook
add address=66.220.144.0/21 comment="Facebook block AS32934" disabled=no \
list=Block-Facebook
add address=66.220.152.0/21 disabled=no list=Block-Facebook
add address=66.220.159.0/24 disabled=no list=Block-Facebook
add address=69.63.176.0/21 disabled=no list=Block-Facebook
add address=69.63.184.0/21 disabled=no list=Block-Facebook
add address=69.171.224.0/20 disabled=no list=Block-Facebook
add address=69.171.239.0/24 disabled=no list=Block-Facebook
add address=69.171.240.0/20 disabled=no list=Block-Facebook
add address=69.171.255.0/24 disabled=no list=Block-Facebook
add address=74.119.76.0/22 disabled=no list=Block-Facebook
add address=204.15.20.0/22 disabled=no list=Block-Facebook
add address=31.13.24.0/21 disabled=no list=Block-Facebook
add address=31.13.64.0/19 disabled=no list=Block-Facebook
add address=31.13.64.0/24 disabled=no list=Block-Facebook
add address=31.13.65.0/24 disabled=no list=Block-Facebook
add address=31.13.66.0/24 disabled=no list=Block-Facebook
add address=31.13.69.0/24 disabled=no list=Block-Facebook
add address=31.13.70.0/24 disabled=no list=Block-Facebook
add address=31.13.71.0/24 disabled=no list=Block-Facebook
add address=31.13.72.0/24 disabled=no list=Block-Facebook
add address=31.13.73.0/24 disabled=no list=Block-Facebook
add address=31.13.74.0/24 disabled=no list=Block-Facebook
add address=31.13.75.0/24 disabled=no list=Block-Facebook
add address=31.13.76.0/24 disabled=no list=Block-Facebook
add address=31.13.77.0/24 disabled=no list=Block-Facebook
add address=31.13.78.0/24 disabled=no list=Block-Facebook
add address=31.13.79.0/24 disabled=no list=Block-Facebook
add address=31.13.80.0/24 disabled=no list=Block-Facebook
add address=31.13.81.0/24 disabled=no list=Block-Facebook
add address=31.13.82.0/24 disabled=no list=Block-Facebook
add address=103.4.96.0/22 disabled=no list=Block-Facebook
add address=173.252.64.0/19 disabled=no list=Block-Facebook
add address=173.252.70.0/24 disabled=no list=Block-Facebook
add address=173.252.96.0/19 disabled=no list=

Accede o Regístrate para comentar.