Backup por Consola y Winbox - Creando backups editables PARTE 2

editado 7 de septiembre en Backups

Anteriormente hemos estado viendo que el backup que se ha creado en el mikrotik es un archivo no editable, este es un archivo binario que no puedes ver que contiene dentro de él, entonces uno si quisiera leer o saber qué tipo de configuración contiene deberá hacer otro tipo de backup, el cual sea editable.

Porqué hacer un archivo editable?

1) La primera razón es que cuando creamos un backup editable, este archivo nos permite observar la toda la configuración que tiene un servidor mikrotik, así que cuando haya algún problema seamos capaces de imprimir esta configuración y pedir ayuda a otra persona, esta persona podrá ver la configuración y verá en donde podría encontrarse los errores. Con ello nos hace la vida más sencilla para solucionar algún tipo de evento que podría fallar.
2) La segunda razón es que nos va a permitir copiar la configuración que podemos encontrar en cualquier foro relacionado a Mikrotik y modificarla para nuestro caso.
Comando EXPORT
Para poder hacer este tipo de backup usamos el comando export, este comando produce un archivo con extensión "src"
Código:

[admin@MikroTik] > export file=configuracion
[admin@MikroTik] >

Vemos dentro de file que existe un archivo creado llamado configuracion con extension rsc
Código:

[admin@MikroTik] > file
[admin@MikroTik] /file> print
NAME TYPE SIZE CREATION-TIME
0 skins directory dec/31/1969 19:00:49
1 configuracion.rsc script 36 659 jun/28/2013 >15:29:19

Visto en la winbox aparecerá la configuración

Ahora veremos que hay dentro del archivo, para ello lo bajamos a la computadora y abrimos con el block de notas

Cuando abrimos el archivo llamado "configuracion.rsc" veremos que hay algo escrito parecido al siguiente codigo
Código:

# jan/02/1970 04:44:10 by RouterOS 5.22
# software id = 2MGR-VJWJ
#
/interface bridge
add admin-mac=00:00:00:00:00:00 ageing-time=5m arp=enabled auto->mac=yes \
disabled=no forward-delay=15s l2mtu=1598 max-message-age=20s >mtu=1500 \
name=LAN priority=0x8000 protocol-mode=none transmit-hold->count=6
/interface ethernet switch
set 0 mirror-source=none mirror-target=none name=switch1
set 1 mirror-source=none mirror-target=none name=switch2
/ip firewall layer7-protocol
/ip hotspot profile
set [ find default=yes ] dns-name="" hotspot-address=0.0.0.0 html->directory=\
hotspot http-cookie-lifetime=3d http-proxy=0.0.0.0:0 login-by=\
cookie,http-chap name=default rate-limit="" smtp-server=0.0.0.0 \
split-user-domain=no use-radius=no
/ip hotspot user profile
set [ find default=yes ] idle-timeout=none keepalive-timeout=2m >name=default \
shared-users=1 status-autorefresh=1m transparent-proxy=no
/ip ipsec proposal
set [ find default=yes ] auth-algorithms=sha1 disabled=no enc->algorithms=3des \
lifetime=30m name=default pfs-group=modp1024
/ppp profile
set 0 change-tcp-mss=yes name=default only-one=default use->compression=\
default use-encryption=default use-mpls=default use-vj-compression=\
default
set 1 change-tcp-mss=yes name=default-encryption only-one=default \
use-compression=default use-encryption=yes use-mpls=default \
use-vj-compression=default
/interface pppoe-client
add ac-name="" add-default-route=yes >allow=pap,chap,mschap1,mschap2 \
dial-on-demand=no disabled=no interface=WAN1 max-mru=1480 max->mtu=1480 \
mrru=disabled name=pppoe-out1 password="" profile=default service->name="" \
use-peer-dns=no user=""
add ac-name="" add-default-route=yes >allow=pap,chap,mschap1,mschap2 \
dial-on-demand=no disabled=no interface=WAN2 max-mru=1480 max->mtu=1480 \
mrru=disabled name=pppoe-out2 password="" profile=default service->name="" \
use-peer-dns=no user=""....................

Algunos podrán observar que ahroa si pueden leer cosas que se encuentran dentro de el archivo de backup, esto es bueno para los que quremos saber como esta la configuracion y ayuda a ayudarlos (disculpen la redundancia).
EL último post trataremos de poder explicarles paso a paso como se puede leer estas configuraciones que se encuentran dentro de cada archivo de backup.
Por el momento nos vemos hasta la proxima

Accede o Regístrate para comentar.