VPN PPTP - Como enlazar Dos Puntos Remotos Usando PPTP Server - PPTP Client

editado 4 de septiembre en VPN


Manos a la Obra en este esquema mostramos:

Configurando la VPN PPTP gateway-to-gateway (De Router a Router)

Mikrotik A (VPN Master):

Primero vamos a configurar básicamente para que tenga Internet

LAN:

/ip address
add address=192.168.1.1/24 broadcast=192.168.1.255 comment="" disabled=no
interface=lan network=192.168.1.0

En este caso la conexión a Internet es por ADSL así que la interfaz de "WAN" obtiene IP mediante el "pppoe-out1" que es su interface virtual del mikrotik.

Muy importante en este es que queden las opciones "add-default-route=yes" y "use-peer-dns=yes". La primera setea la ruta por defecto y la segunda permite que se usen los DNS del ISP (Opcional).

Activando esta Opciones Hacemos que mikrotik sea de DNS server para la red 192.168.1.0/24

/ip dns
set allow-remote-requests=yes

Configuramos el "masquerade" para que haga NAT de las IP de la LAN por la IP publica hacia Internet para este caso seria pppoe-out1.

/ip firewall nat
add action=masquerade chain=srcnat comment="" disabled=no out-interface=pppoe-out1

Mikrotik B (VPN Esclavo):

Hacemos Una replica del primero.

LAN:

/ip address
add address=192.168.100.1/24 broadcast=192.168.100.255 comment="" disabled=no
interface=lan network=192.168.100.0

/ip dns
set allow-remote-requests=yes

/ip firewall nat
add action=masquerade chain=srcnat comment="" disabled=no out-interface=pppoe-out1

Una vez Realizado la configuración plana procedemos a configurar la VPN sigamos.

MIKROTIK A

Activamos PPTP Server

Creamos la cuenta VPN cliente usuario password tipo de VPN y su IP Local y IP destino mejor dicho del cliente en este caso seria 10.10.10.2

Revisamos los perfiles del servidor

MIKROTIK B (Cliente) Creamos un cliente PPTP CLIENT

Configuramos : Ponemos IP del servidor Mikrotik A el usuario creado y el password.

Luego nos saldrá este símbolo R ppp-out Quiere decir que la conexión ha sigo satisfactoria.


Ahora vemos la prueba de fuego:

Le hacemos ping al mikrotik A

Le hacemos ping al mikrotik B

Listo las pruebas son satisfactorias.

Accede o Regístrate para comentar.